Asteroids / Asteroids Deluxe Repairs

Asteroids Deluxe, Missing Sounds (Ship fire, shield, etc) (12/12/23)

  1. This was annoying as I should have figured it out quickly. Replaced LM324 for the heck of it. Was being lazy, but no change. 
  2. Did some actual troubleshooting, the ”EXPLOSND” and “SHPSND” were intact, all other sounds are missing. 
  3. Replaced socket at Pokey, one of the legs broke when I removed the shell, figured this was the issue.  Nope, still not working.
  4. Probing around the sound circuit, everything looks good.  You can actually hear the fire sounds and other sounds on the logic probe at pin 37 of Pokey chip.
  5. Not much after this in the circuit, checked resistors, replaced C30, but no change and didn’t really expect any as the other sounds are working.
  6. Finally dawned on me to check on continuity from pin 37 of Poke to C30/R67. Sure enough, I don’t have any. Pull the Pokey chip and see that the trace under the pokey (on top of board) is broken. Weird issue due to its location, trace as covered by Pokey, maybe somebody broke it when they removed the Pokey at some point.
  7. Repaired broken trace and board works.

Asteroids Deluxe, Dead (3/17/20)

  1. Board doesn’t do much of anything, cleaned roms, processor, nothing on power-up, board was watchdogging.
  2. Used Fluke to test roms, four program roms didn’t pass, two vector roms did pass, thought something was wrong between processor and roms, but no luck.
  3. Tested two 2114 rams with Fluke 9010a and failed test, replaced L1 and M1 and board now beeps five long and short beep.
  4. Replaced 2114 at P3 per manual and board now boots with video issues, kind of resets and has smallish issues in attract mode, but test mode appears okay. Sometimes jumps between test mode and game mode (with video issues).
  5. Spent a good 30 minutes trying to track this one down, finally pulled the Fluke 9010a back out to retest all roms and rams and the board played perfectly running on Fluke 6502 pod.
  6. Installed another 6502A processor and board works. Never seen a processor partially fail like this (it was kind of half working).

Asteroids Deluxe, Dead (3/16/20)

  1. Board doesn’t do much of anything, cleaned roms, processor, nothing on power-up, board was watchdogging.
  2. Used 9010a to test roms, none of them passed rom test.  Probed around on address lines, A7, pin 1 of roms stuck low. Input at 74LS244 (C1), pin 2 was active, output, pin 18 was stuck low.
  3. Replaced C1 and board now boots with video issues, asteroids stretched, video off.
  1. No activity on DACx8 line, pin 5 at D11 is stuck low. Output at D/E10, 74LS157, pin 4 is stuck low, inputs look okay.
  2. Replaced D/E10 and pin 4 is now pulsing, video still distorted, but maybe slightly better?
  1. No activity on DACx6 line, pin 7 at D11 is stuck low. Pin 6, D10 stuck low, replaced D/E10 again and picture much better, first “new” 74LS157 was apparently bad.
  1. Probing around vector circuits, found pin 7 at F8, 7497 was stuck low. Replaced F8 to fix issue. Board now works…
  2. While typing up repair look over to see some large lines on screen, looks like player ship is now screw up.  
  3. Quickly found output at 74LS175 at M6, pin 6 was stuck low. Replaced M6 to fix board, again.
  4. Board lasted a few more hours before developing video issues during bench testing.
  5.  Found dead outputs at A10, 74LS157, Logic Comparator confirmed IC was bad, replaced it and picture improved, but still not right.
  6. Output at D10, pin 9 was high (74LS374), input was pulsing. Replaced D10 and image is back to normal (again).
  7. Guess, board developed issues again during testing.  
  8. This time looked like something on the Y-axis before the DAC, took a little while to figure this out as all inputs to the DAC were pulsing, I was sure the everything the  Y Position counters circuit was okay. Finally noticed to DACY7* input to the DAC was pulsing but not right (used scope to notice it). Replaced 74LS374 at B10 to fix the problem.

Asteroids Deluxe Beeps (3/16/20)

  1. Board beeps on power up, two high beeps, one low beep. Manual indicates bad 2114 ram at M3.
  2. Removed suspected ram, installed new socket and new ram and board works.

Asteroids, Thump and Ship Fire sounds Clicking (11/30/23) -05 Revision Board

  1. Thought this board was fully working, apparently not.  Thump would be a small click, C33 had already been replaced. Replaced 555 timer at N9 to fix the thump issue.
  2. Ship fire was the 555 time at L10, replaced it and it now works.

Asteroids, Video Issue, Resets, Was Ok (11/20/23)

  1. Another one of those boards that drove me nuts fixing.  This one was fine and during bench testing it started acting up. I’d get a double image of the scores and sometimes see a large / big saucer appear.  In test mode I’d get a test pattern and then a diagonal line with a quick beep. Sometimes board would run fine for 5-10 seconds without resetting.
  2. I thought this was something in the VSM based on a prior repair. Spent a bit of time probing around, replaced an IC or two, but no change.
  3. Used the Fluke 9010a to test the bus and ram again. Gave me a ram error on 4300-47FF range. Replaced 2114 at P4 and it passed the test, good. 
  4. Board continues to act up, more probing around and then decide to use the freeze spray as sometimes it does work for 5-10 seconds. Maybe its heat related?  Spraying around and noticed that when I spray 2114 ram at R4 board gets a bit crazier.
  5. Replaced R4 ram and board now works. Apparently the Fluke either couldn’t detect the bad ram when I retested it or I tested while it was acting up.

Asteroids, Clean Board (11/18/23) - resetting / video issues

  1. This was a rewarding repair with fairly clean board. Replaced the processor and rom sockets.  Board doesn’t do much on boot. No reset, check board and it was missing the crystal.
  2. Board now has a clock and is watchdogging.
  3. Used Fluke 9010a to verify roms, I had them installed in the wrong order, this was an -05 board they go in the reverse order.  Roms now verified good.
  4. Board fails ram test at R/W ERROR @0100 BTS3. Bad bit 3 equals DB2, which means 2114 at L2 is bad. Replace this ram and board passes all ram tests now.
  5. Board boots to scrambled video over test mode screen with some other random stuff (large ship in center of screen). It is clearly resetting. Switching to test mode gets me a constant beeping.
  6. Pull 74LS42 at L6 and leave pin 1 to confirm a VSM issue (which I suspected).  Probing around VSM, I don’t see anything wrong, but did replace 74LS193 at J5 as I thought it might be bad, no change (more later).
  7. Socket the prom at C9 to confirm that is good and test it on another board, it is fine.  Spent a good hour looking for something with no luck. Come back to the Vector Generator Memory Address Selector as I recall yesterday checking the 74LS157s with a logic comparator and at one point the beeping stopped (which is why I suspected J5 earlier).
  8. Start checking 74LS157s again with a logic comparator and eventually get the beeping to stop at K3.  IT didn’t stop every time I tested, but did once or twice. Replaced K3 and the board now works.  Was about to walk away if that didn’t fix the issue. 

Asteroids, Dead Board (3/13/20)

  1. Installed new processor and rom sockets as preventative maintenance, board plays beeps constantly in test mode, it is watchdogging.
  2. Use 9010a to test rams and roms, everything checks out okay.
  3. Replaced L6 to lift pin 1 to isolate program code from vector generator, board plays blind.
  4. Replaced 74KS42 at E7 and 74LS175 at M7, thought they might be the issue, no change.
  5. Swapped out Prom at C8, board now plays blind (no more watchdogging).
  6. Replaced TL082 at A12 as piggybacking led to some vectors.  Board now has some bad video.
  7. Replaced TL081 at B/C12 as piggybacking helped, slightly better picture, but everything now collapsed on Y axis, asteroids looked squished.
  8. Found bad output, pin 6 on 7497 at H8, replacing that brought picture back perfectly.

Asteroids Dead Board (3/3/20)

  1. Installed new processor and rom sockets as preventative maintenance, board plays blind, no Z output activity.
  2. Found bad leg (it wasn’t reaching board) 74LS109 IC at A9.  (D8 pin 14, HALT line was not pulsing).
  3. Board now works but 00 in score are off on boot (kind of misaligned) for about 10-20 seconds. Voltage at 4016s was -8.4 VDC at boot.  Replaced most caps in circuit and it seems to better, still a little high on boot, but calms down quickly.

Asteroids, Dead Board

  1. Installed new 6502 socket as these are usually touchy or bad.
  2. Missing crystal, replaced that board came up with random vectors. Did NOT play blind.
  3. Put in test mode, beeps indicated bad 2114 ram at M4. 
  4. Replaced M4 and board came up with collapsed, distorted video, but did appear to be playing.
  5. Found a bad 4016 in vector output section at B13 which corrected video issue.
  6. Game was working, but sounds off a bit, asteroids explosion scratchy at times, saucer sounds off a little, started by replacing LM324 as I’ve seen these fail often on Atari boards and that fixed the sound issue.
  7. During burn-in board shut down, due to touchy rom sockets, push on the rom it would came back up. All rom sockets replaced solved this problem (I know going in I’d have to replace them all anyway was just trying to get board up and running first).

Asteroids, Okay in test mode, resets in game mode with some graphics at the bottom of the screen (11/5/14)  - All ram and roms checked out with Fluke. Reading through other repair logs found one reference to a similar problem that was at 74Ls191 counter at K5. Checked outputs at pins 2 and 3 and they were dead, all of the inputs looked good. Replaced K5 to fix the problem.

Asteroids, Nothing on Screen, Dead (12/5/11) – Boardset came up, did not play blind, nothing.  First thing I checked were the roms, they were all bad, I replaced them all and then put the game in test mode and a got a short beep (Bad Ram #1). Replaced Ram #1, but no change. Reset line was barking, tried replacing E4 as I read this can cause the board report Ram errors when the Ram good, but I didn’t think it was the problem.  No change, so I starting looking at Ram lines and noticed some dead lines on Ram#2. I changed this Ram and the game fired right up.  Was a little a shaky at times, so I replaced the pots and it is has been solid since then.

After giving up on this one last year, I pulled it back out of the box today.  Pretty much replaced almost everything in the X circuit as suggested and no changed.  Noticed that one I removed TL082 at E12 the screen looked better and figured maybe it was something in the final output section.  Finally figured out that my 8.2 VDC at D12 was at 5.2 VDC. Tracked this down to a bad 8.2 VDC zener diode at